Page 1 of 1

HELP! I can't download the new update for Pinball Arcade (PS4)

Posted: March 11th, 2017, 11:38 am
by astrodomekid
I've been waiting anxiously for the Doctor Who table to arrive on the PS4 version of Pinball Arcade. So when I received an email from the creators showing that Season 6 has finally been released for that version, I immediately went to my PS4 to buy it. But when I started the game, it wasn't detected. Everything was the way it was before. So of course, I had to update the app to make the table playable. But when I tried to check for the new update, it said that it was at the latest version (1.15 if you're wondering). At first, I assumed that the update required to play it had not been released yet, and that the Season Pass was introduced early. But when I tried Google, it has been out since day one. And nobody else (that I could find) was having this issue. This is an S.O.S. going across the Pinball Arcade community, as I am in desperate need of a solution. Please help!